Noticias:

¿Deseas poder tener acceso a contenido exclusivo? ¿Tu propia zona? entonces mira esto: Platinum [Leer]

Menú principal

[Ayuda] Problema con el Automatic Index v3

Publicado por jotade, 08 Enero de 2022, 02:08

Tema anterior - Siguiente tema

0 Usuarios y 1 Visitante están viendo este tema.

jotade

Buenas, gente!!

Primero que nada, espero que hayáis tenido buen comienzo de año!! Tengo un problema con el siguiente mod:

https://www.smfsimple.com/index.php?topic=9361.0

No sé si es correcto pedir soporte aquí, pero por lo que sé, y por lo que veo, smfsimple está bastante apagado, teniendo modificaciones muy buenas, que corren de la mano de 4kstore.

Rock, como tú sueles conocer el estilo de programación de los, llamémosles precursores de mods, necesito que me eches una mano. Verás, con este mod me ocurre EXACTAMENTE LO MISMO QUE CON EL MOD SLIDE PRO, funcionan ambos perfectamente, el problema surge cuando meto la pata (me ocurre a menudo), y tengo que borrar el foro, e importarlo de nuevo, el foro tira error en todos los lados, el archivo en ambos poniendo el focus en el index, ocurre en autoindexhook.php dentro de la carpeta recursos (sources), cualquier modificación, a posteriori, ya sea volver a importar exactamente el mismo archivo, como modificarlo ligeramente, que haga a ese archivo, una vez instalado el mod, me revienta el foro... No soy capaz de averiguar el motivo...

Para reproducir el error debes:

1º instalar el mod indicado
2º una vez instalado el mod, modificar ese archivo, y resubirlo O simplemente después de instalado, borrar el foro, y resubirlo, te dará un error que te inutilizará el foro, siendo solo subsanable eliminando el archivo mencionado.

Como es lógico, no se puede estar borrando un archivo, borrando el mod (dejando restos de código posiblemente), y volviendo a instalar para que funcione. ¿Puedes echarme una mano para subsanarlo?

Muchas gracias.

Rock Lee

Bueno tambien tenes que tener en cuenta que debe quedar valores en la base de datos muchos mods no borran muy bien los valores usan por eso te da problemas y el archivo te marca error por eso mismo por valor duplicado o en este caso el hook queda "huerfano". Tenes usar el repair settings que te da la opcion de borrar todos los hooks relacionados, con eso deberia funcionar todo nuevamente sin problemas... sino queda importar tablas puntuales pero necesitas saber mas sobre mysql/mariadb.


Saludos Familia!

jotade

Cita de: Rock Lee en 08 Enero de 2022, 21:13
Bueno tambien tenes que tener en cuenta que debe quedar valores en la base de datos muchos mods no borran muy bien los valores usan por eso te da problemas y el archivo te marca error por eso mismo por valor duplicado o en este caso el hook queda "huerfano". Tenes usar el repair settings que te da la opcion de borrar todos los hooks relacionados, con eso deberia funcionar todo nuevamente sin problemas... sino queda importar tablas puntuales pero necesitas saber mas sobre mysql/mariadb.


Saludos Familia!

Si mal no he entendido, el problema está en restos que quedan en la DB, ¿hay alguna tabla a la que se asocien los datos de las hooks? Para echar un vistazo y borrar manualmente lo que no se elimina.

Gracias!!

Rock Lee

Si basicamente aunque cada modificacion cambia donde lo guarda (depende mucho del creador) pero en estos años en lineas generales he visto que suelen estar mayormente en la tabla settings o boards igualmente como te comente mas arriba algo mas simple y rapido es usar la funcion integrada del repair settings para borrar todo rastro. Sino muy de ultima quitar manualmente lo que llegue a quedar pero son contado con la mano donde sucede esto...


Saludos Familia!

Temas Similares (5)