Noticias:

¿Deseas poder tener acceso a contenido exclusivo? ¿Tu propia zona? entonces mira esto: Platinum [Leer]

Menú principal

Generador de Funciones HP 33120A

Publicado por rafik, 19 Octubre de 2021, 01:51

Tema anterior - Siguiente tema

0 Usuarios y 1 Visitante están viendo este tema.

rafik

Hola Queridos amigos, soy un pequeño aficionado a la electronica y deseo compartir con ustedes la reparacion que se hizo de uno de mis GF HP33120A con la ayuda de un colega desinteresado.
Esto fue a inicios de año. Pero pueda que a alguien le sirva como se reparo.
Ya hace unos años solicité ayuda para la reparación de mi tek 2465B. Por cierto, se avanzó mucho, pero no se reparó porque no tenía mucho tiempo por trabajo; Te dejo saber esto. Ahora las cosas son diferentes.

Bueno, durante el año pasado tuve la posibilidad de adquirir dos HP33120A pero ambos tienen fallas. Las series son US34012072 y US34017139

Con respecto al US34012072, el que estoy tratando de reparar primero, no tiene salida de onda cuadrada, todas las demás señales están bien.
En el diagrama esquemático de Sincronización, Onda Cuadrada y Atenuador, ubiqué el transistor Q605 y en la base hay un poco más de 12 voltios. Me parece que es demasiado. Seguí retrocediendo y encontré que la señal SW_AMPL no está presente, seguí retrocediendo más y llegué a U303 AD1851R, en el Esquema del Sistema DAC, donde hay una señal de "Datos" en el pin 7, pero creo que no es correcto . Adjunto una foto de esta señal de datos.
Aquí es donde me detengo.
Mi pregunta es ¿puedo probar este IC para saber si está defectuoso? ¿Cómo sabré si esta es la falla?
Como dato adicional, cuando hago la autocomprobación y todas las pruebas, pasa.

Aquí en mi país estos equipos ya no se reparan y cuando se dese  reparar se envian a Estados Unidos.
Espero vuestra comprensión. Se agradecería cualquier sugerencia y consejo.
Gracias de antemano por su atención.
73!

rafik

Continuando, el colega me aconseja asi:
Permítanme comenzar con la pregunta del DAC, no creo que el problema esté en el DAC si otras funciones funcionan bien. DAC genera varios voltajes en la misma hoja, su salida pasa por un mux analógico y etapas de muestreo y retención. Si algo andaba mal con el DAC, casi todo fallaría. Si desea observar las señales al DAC de todos modos, dispare en el borde descendente del pin 6 "LE", observe CLK y el zoom de DATOS para que pueda ver CLK. Mire la hoja de datos del DAC para decodificar. Sin embargo, DAC parece estar bien.

> Me parece que es demasiado. Seguí retrocediendo y encontré que la señal SW_AMPL no está presente,

¿Qué voltaje ves en SW_AMPL?
¿Qué voltaje ve en C303?

Podría ser simplemente que las constantes de calibración para Square Wave sean incorrectas. Puede probar la sección de calibración "Ajuste del ciclo de trabajo".
Realize las mediciones y..

La conclusión que ha hecho con respecto al DAC tiene sentido, para mí está clara.

El voltaje en SW_AMPL es: -3,68v
Y en C303 es: 3,75v

SW_AMP debería ser nominalmente 2x el voltaje en C303. Esta es la configuración común de amplificador operacional no inversor.
Algo anda mal en esta área según los voltajes que midió (confirme nuevamente).
En U306:
¿Son correctos los suministros (patilla 4 a + 15V, patilla 11 a -15V)?
¿El voltaje del pin 9 está cerca (dentro de unos pocos mV) del voltaje del pin 10? La retroalimentación de Opamp debe intentar hacer que ambas entradas sean iguales.
RP302 tiene un controlador de 1/2 voltaje (dos RP302 de 10k ohmios), el voltaje en el pin 9 debe ser la mitad del voltaje en el pin 8.

Es posible que el opamp debe retirarse.

La reparacion tomo varios dias pero finalmente se concluyo:

Correcto, U304 74HC4051D es el sospechoso.

La razón es que el pin3 (entrada) no tiene ningún voltaje tan bajo como el que está viendo en la salida. Algo está mal con el interruptor analógico en la ruta SW_AMPL, probablemente el NMOS del interruptor tiene una fuga en la puerta.

Finalmente reemplacé U304 y aparecio la onda cuadrada pero hay una especie de barrido o modulación en la señal. No he podido encontrar la causa.
Cualquier sugerencia será apreciada. Gracias de antemano
Adjunto un video.

Para solucionar aquella ondulacion revise la fuente como me sugirio nuestro colega,
Revisé los condensadores de los suministros y todos estaban bien. Pero como sugirio, decidí especialmente revisar el C1001, lo medí y todo estaba bien, pero cuando lo quité, noté que había una mala conexión en la soldadura.
Limpié la zona y la soldé de nuevo y la avería desapareció.

¡Generador de señales de función arbitraria Hp 33120A reparado!

--Great news and congratulations for fixing the 33120A. Thank you very much Sir!  73!


Temas Similares (5)